broken anti-spam token prevented comments

Apparently some people were not able to leave comments here in the blog section for a while due to some server permissions error that prevented our “anti-spam captcha” thing from working properly. Big apologies to anyone who tried to leave a comment here and then got some weird frustrating token error or something. I have removed this captcha thing for today while I investigate what the issue was.


I take comments here seriously and want to make it as easy as possible for everyone to add to discussions here. Finding out that this anti-spam thing was broken and preventing comments really ticks me off. Not sure how long this has been an issue here, hopefully not very long! If anyone runs into this kind of issue again, or anything similar where a comment is made but does not get published, please contact me to look into the issue.

On the contact us page if you send a manual email to the email addy published on that page it will get seen faster than the comments that are added to the form there. I try to check that email addy a few times a day, and messages sent via our forms can easily get lost in the shuffle or not seen for weeks, as we are completely inundated with spam emails, spam comments, and all kinds of other random messages.

Granted, when comments do work properly, the first time someone leaves one here it will be “held in moderation awaiting approval” – until I wake up and click the okay this is not spam button. So if you make a comment you may see something on the screen telling you it’s waiting and others will not be able to see it publicly until it is cleared.

That is just one layer of our prevent spam system here, and it’s an unfortunate necessary evil we must endure to prevent this huge amount of bullshit comments being published everyday offering everything from sex pills to make thousands of dollars easily from home fake stuff.

I had written a blog post a little while back that warned of some updates and changes to our commenting and blog system here. Of course if no one was able to leave a comment saying they were not working, then I guess that was a double problem! Hopefully we won’t have this issue again, I’ll keep a closer eye on this system when we roll out the next updates.

Trying to maintain the perfect line of open discussions and limiting spam is more work than I ever imagined, and not as easy as I’d like it to be!


Leave a Reply

Your email address will not be published. Required fields are marked *